It is currently Fri Nov 24, 2017 1:05 am

All times are UTC - 8 hours




Post new topic Reply to topic  [ 23 posts ]  Go to page Previous  1, 2, 3
Author Message
PostPosted: Thu Dec 05, 2013 10:18 am 
Offline
Rogue

Joined: Fri Nov 01, 2013 11:27 am
Posts: 57
carnuck wrote:
Reach up behind and pull the bulb out then check for power drain at the battery


That's the plan.

Is that bulb easy to get to or does anything need to get yanked? I just had the whole cluster out a few months back to replace bulbs...lol


Top
 Profile  
 
PostPosted: Thu Dec 05, 2013 10:43 am 
Offline
Hornet
User avatar

Joined: Thu May 02, 2013 10:40 am
Posts: 1175
Location: North Seattle sort of
Sounds like you put one in the wrong place! I don't recall anything in the way but last time I did it was a non-AC car. I have the whole dash from my '84 sitting in my parts shed. One day I'll get around to posting it for sale. This past summer I eliminated 3 five ton truckloads of parts from my collection. I'm now down to a Grumman van, my shed and Max98059's garage full.

_________________
'87 Comanche 4x4 $3500 http://forums.amcevolution.com/viewtopic.php?f=16&t=1355
Image


Top
 Profile  
 
PostPosted: Thu Dec 05, 2013 12:07 pm 
Offline
Rogue

Joined: Fri Nov 01, 2013 11:27 am
Posts: 57
carnuck wrote:
Sounds like you put one in the wrong place! I don't recall anything in the way but last time I did it was a non-AC car. I have the whole dash from my '84 sitting in my parts shed. One day I'll get around to posting it for sale. This past summer I eliminated 3 five ton truckloads of parts from my collection. I'm now down to a Grumman van, my shed and Max98059's garage full.


Sounds like some parts collection! I only replaced bulbs that were blown and turned black. There were a couple of spots with blanks like the upshift indicator.

Can't reach the EM bulb. I can get to the speedo cable but that's about it, this car has AC.

Just spent some time digging thru the FSM and it says there is an "E-Cell" timer(good for 1,000 hours) in use on the 1984 models but that's about all the book says. There is a wiring diagram that shows the EM light circuit and the E-Cell timer with 3 wires: a GRAY(to the bulb), BLACK(ground), and YELLOW W/TR(to ignition switch) but all the FSM says is that the E-Cell timer is "located in passenger compartment" which doesn't really help. Looked up under the dash but I can't see it.

There is a definite drain at the battery when the key is off which leads me to believe that it's more than just a #194 bulb. Judging by the wiring diagram there are only 2 possibilities: bad ignition switch or bad E-Cell timer. Gotta find this elusive E-Cell timer.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 23 posts ]  Go to page Previous  1, 2, 3

All times are UTC - 8 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Reputation System ©