AMC Evolution AMC Eagle Forums
http://forums.amcevolution.com/

Electrical question
http://forums.amcevolution.com/viewtopic.php?f=30&t=2031
Page 1 of 1

Author:  shilmer [ Sat Sep 13, 2014 8:40 am ]
Post subject:  Electrical question

Both rear turn lamps stay on all the time. I ave pulled the fuse and pulled the flasher and they stay on constantly. Why? What do I do?

Author:  Mernsy [ Sat Sep 13, 2014 11:01 am ]
Post subject:  Re: Electrical question

Wonder if it's your brake lights? Check the switch halfway up the brake pedal.

Author:  shilmer [ Sat Sep 13, 2014 11:24 am ]
Post subject:  Re: Electrical question

it is on an 84 eagle. the turn lamps on the rear are in a separate part of the tail light housing. the turn lights are yellow on these. i pulled the hazard flasher and the turn signal fuse but they are still on. if i turn on the right signal the left stays lit but the right will flash fine if i turn on the left nothing happens but the indicator light on the dash comes on but dim and no flashing. is there another flasher unit that i am not aware of.

Author:  Mernsy [ Sun Sep 14, 2014 3:39 am ]
Post subject:  Re: Electrical question

There's a flasher way up under the dash, on the left side near the windshield. It's hard to get to but it's up in there.
I presume you've checked the bulbs and grounds?

Author:  carnuck [ Sat Sep 20, 2014 10:40 am ]
Post subject:  Re: Electrical question

Wrong bulb in one socket or do the lights come on only when signal is switched? If they come on but don't blink, that means the front bulb is burnt out. (not enough resistance to make the blinker flash)

Author:  amchornet [ Sun Sep 21, 2014 3:41 am ]
Post subject:  Re: Electrical question

yes there are two flashers....one for the hazards and one for the turn sig.

Page 1 of 1 All times are UTC - 8 hours
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/