AMC Evolution AMC Eagle Forums
http://forums.amcevolution.com/

80 wagon
http://forums.amcevolution.com/viewtopic.php?f=13&t=2210
Page 1 of 1

Author:  CometJunkie64 [ Thu Jun 29, 2017 5:03 pm ]
Post subject:  80 wagon

Hey guys, new to eagles but not new to Ramblers/AMC's. I recently picked up my 80 wagon. Fairly low mileage car with 87,000 miles. It was running a little rough due to an intake leak and a carb that was on it's last legs
The guy I picked it up from said that it's been a common mod for the 4.2 to install a motorcraft 2bbl. The idea seems good but the install left much to be desired. It didn't have full throttle. I had another carb around so I installed it and snugged up the intake and she's running great. With the different linkage for the butterflies so built a bracket to move the throttle cable up the the carb. Unfortunately it removed the kick down. Finally drive it the other day and it rides great! Well until it stopped haha... driving home the other night the car just cut out. No warning. Figured that it stalled out so I bumped it into neutral and bumped the key. Still nothing. So I rolled into a parking lot, thought maybe it just needed to be in park. Still nothing. All lights working, just no ignition or accessory. Started digging and found some cobbled up, spliced wires that run from the alternator. I'm going to try replacing the bad wire tomorrow to see if it helps. Is there anything else anyone can think of that may point me in the right direction?
Thanks
Clifton

Page 1 of 1 All times are UTC - 8 hours
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/