It is currently Sat Sep 23, 2017 1:06 am

All times are UTC - 8 hours




Post new topic Reply to topic  [ 171 posts ]  Go to page 1, 2, 3, 4, 5 ... 18  Next
Author Message
 Post subject: 1981 Eagle SX4 Project!
PostPosted: Sun Oct 20, 2013 5:54 pm 
Offline
Javelin

Joined: Mon Oct 14, 2013 7:35 am
Posts: 224
Location: Bloomsburg, PA
So after much searching in the past few weeks and a lot of work this weekend, I am the proud owner of a very solid and running AMC Eagle SX4. Inline 6, auto transmission. Nearly no rust, however, there are quite a few missing trim pieces. A donor car will hopefully fill in the missing pieces unless I can find them somewhere else for cheap enough. The car needs a new interior basically and will need some wiring work done to it, hopefully not too much. I hate electrical gremlins.

Anyway, the car, more photos will follow once I get the car into my garage next weekend:
Image

The plan:
Fix the brakes, they are very weak, might just need bled.
Replace all the missing trim/lights and other pieces.
Sort all the electrical problems
Replace interior

Future:
AX15 5 speed swap
Engine rebuild with forged internals for future turbo.
EFI via Megasquirt
Turbo or possibly supercharge the motor for a small amount of boost.
Paint

Other photos of the decrepit Eagle. Interior is a mess, carpets need replaced in the passenger compartment, I'm praying I don't find a world of rust under them.. I will probably cry at that point.
Image

Image

Image

Image

Image

Image

Image

Image

Image

Image

Image

Image
Drivers seat..
Image
Passenger... Both need replaced.
Image
Rear isn't too bad. No holes that I could see.
Image
Like I said.. Carpets need to go..
Image
More carpet damage.. The carpet is deteriorated so badly that I can pull pieces of it apart with my fingers and little force..
Image
On the upside, the rear is very nice and cleaned up very well with a bit of vacuuming.
Image
Both armrests are falling apart. They seem to be in OK shape, but they aren't exactly held on very well.
Image


Last edited by dleberfinger on Thu Oct 31, 2013 8:47 am, edited 2 times in total.

Top
 Profile  
 
PostPosted: Sun Oct 20, 2013 6:11 pm 
Offline
Pacer

Joined: Sat Jun 01, 2013 3:03 am
Posts: 857
I have front signal lights and a rear bumper, black SX4 trim.


Top
 Profile  
 
PostPosted: Sun Oct 20, 2013 6:14 pm 
Offline
Javelin

Joined: Mon Oct 14, 2013 7:35 am
Posts: 224
Location: Bloomsburg, PA
SpreadEagle wrote:
I have front signal lights and a rear bumper, black SX4 trim.


How much? I'm thinking about this donor car because I'm afraid buying all the parts is going to cost just about the same as the donor.

Thinking about picking up a donor SX4 for $650. Anyone see anything wrong with that? It's $220 in scrap. Can I make up the difference with selling the parts on it? No spoiler and auto. I need the engine from it too, so that works out to about $100 that I would pay otherwise. Trying to make up about $300 difference.


Top
 Profile  
 
PostPosted: Fri Oct 25, 2013 3:14 pm 
Offline
Javelin

Joined: Mon Oct 14, 2013 7:35 am
Posts: 224
Location: Bloomsburg, PA
Some parts coming in before I even have my Eagle! Haha.. Rear brake spring and hardware kit and fresh plugs.

Image

Heading down to get my car around 10 in the morning, photos will follow once I get it into my driveway.


Top
 Profile  
 
PostPosted: Sat Oct 26, 2013 7:59 pm 
Offline
Hornet
User avatar

Joined: Thu May 02, 2013 10:40 am
Posts: 1175
Location: North Seattle sort of
I don't know if those plugs will have the same issue as the Bosch Platinums. I don't run them in US vehicles anymore due to ping, hard starting and misfire after 30 days when running HEI.

_________________
'87 Comanche 4x4 $3500 http://forums.amcevolution.com/viewtopic.php?f=16&t=1355
Image


Top
 Profile  
 
PostPosted: Sun Oct 27, 2013 8:11 am 
Offline
Javelin

Joined: Mon Oct 14, 2013 7:35 am
Posts: 224
Location: Bloomsburg, PA
carnuck wrote:
I don't know if those plugs will have the same issue as the Bosch Platinums. I don't run them in US vehicles anymore due to ping, hard starting and misfire after 30 days when running HEI.


Hmm, that's the first I've heard anyone having trouble with them. I've run them in my 08 Accord, my air cooled VW engines, my four wheeler.. They all seem to work great with them. I'll have to watch out when I put them in..

So I drained the oil last night. The car is supposed to take 5 QTs US, if I'm not mistaken. That being said I drained almost 10 QTs of fluid and it was the consistency of water and was definitely a lot of gas and not as much oil as it should have been. I'm not sure how long the engine sat, however it fires right up on every start and seems to idle off very nicely. Worst case scenario what would cause that amount of gas in the oil? Bad rings? Head gasket?

How quickly should the gas be coming out of the filter into the carb? I was having trouble when I first started it with getting gas to the engine, I think it may have just needed primed after all those years of sitting. I pulled the line off the carb and blew it out and then turned the engine over with it off the carb. Gas comes out but not too quickly. I'm not too familiar with newer engines, however my old air cooled VW engine used to spit gas like crazy if the line came off the carb.

When the engine was running before oil was leaking from a few spots. After I drained the old and put in new it doesn't seem to be leaking anywhere. There seems to be a good bit of smoke coming off the engine, however it doesn't happen until it starts to warm up. So I'm not sure if it's just oil and stuff on the block and exhaust or not. Guess we will have to wait and see if it persists.


Top
 Profile  
 
PostPosted: Sun Oct 27, 2013 11:25 am 
Offline
Rebel
User avatar

Joined: Mon Oct 14, 2013 2:07 pm
Posts: 115
Location: Lancaster PA
More like heavy float, needle and seat, choke not coming off right.

_________________
Don't follow me, you won't make it.
http://www.garyschatzautorepair.com/


Top
 Profile  
 
PostPosted: Sun Oct 27, 2013 11:56 am 
Offline
Javelin

Joined: Mon Oct 14, 2013 7:35 am
Posts: 224
Location: Bloomsburg, PA
Maybe. Either way I haven't had trouble starting it since then so we will see.


Top
 Profile  
 
PostPosted: Sun Oct 27, 2013 7:06 pm 
Offline
Hornet
User avatar

Joined: Tue Feb 12, 2013 6:39 pm
Posts: 922
if you got gas going into the oil, the only way that can happen is if you have a bad diaphram in the fuel pump. it leaks into the block thru the hole for the pump shaft. are you sure it was fuel and not water?

_________________
dave

WHEN IN DOUBT, BUY MORE BEER!!!!

ASE cert. mechanic 15 years.

http://www.picasaweb.google.com/das24rules

62 rambler classic (casper)
63 rambler american (rosie)
82 eagle sx4 (honeybadger)
82 eagle sw (rottywagon)
79 spirit (drag race car)


Top
 Profile  
 
PostPosted: Sun Oct 27, 2013 7:27 pm 
Offline
Javelin

Joined: Mon Oct 14, 2013 7:35 am
Posts: 224
Location: Bloomsburg, PA
casper wrote:
if you got gas going into the oil, the only way that can happen is if you have a bad diaphram in the fuel pump. it leaks into the block thru the hole for the pump shaft. are you sure it was fuel and not water?


Smelled very much like gasoline. My coat that had it on it was washed and it still smells like gasoline. I have a new fuel pump gasket, but not a new diaphragm I don't think.. I'm trying to get brakes done next weekend, but I will definitely check the fuel pump. I'm guessing I'd just have to replace the pump if the diaphragm is bad?

Also, how can I tell what transfer case I have? I'm thinking I have the 119 as I don't see anyway to shift the drive.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 171 posts ]  Go to page 1, 2, 3, 4, 5 ... 18  Next

All times are UTC - 8 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Reputation System ©