It is currently Tue Dec 12, 2017 7:46 am

All times are UTC - 8 hours




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Mon Jun 10, 2013 10:40 pm 
Offline
Hornet
User avatar

Joined: Tue Feb 12, 2013 6:39 pm
Posts: 922
I bought this '82 wagon a year and a half ago. done a little tinkerin with it and got it running. I have put on about 1000 miles. it currently has 20,932 miles as of tonight. it has power driver seat, a/c (that tonight was blowing at 28* with outside ambient air temp of 84*) cruise control (that still works) and a quite strait body. (left rear corner has a crunch just infront of the tail light. I have only tossed on a few old parts from honeybadger, and some other not used parts. (the edelbrock 500 cfm 4bbl carb for one) the car fires up and runs great. but needs to keep having little things done with it. it was owned by my neighbors who drove it once a month, for about 4 months a year. only to go to town for groceries about 70 miles one way form the ranch they owned. it got parked when the fuel pump had a small leak and cought fire. they replaced the fuel pump, but couldn't get it to run. there are some wires around the ignition stuff (dizzy, icm, plug wires ect) that got burnt. I fixed a few so far. and it runs really good with burnt plug wires, burnt dizzy connection plug, the coil primary wires are both bare. but I still drive it once in a while. heres a video of proof. has belts still with the AMC logos, all plug wires have amc logos, lower rad hose still has amc logo, 2 of the heater hoses still have amc logos also. (I think I should replace all those amc logo'd hoses/belts no?)

this was recorded tonight.


_________________
dave

WHEN IN DOUBT, BUY MORE BEER!!!!

ASE cert. mechanic 15 years.

http://www.picasaweb.google.com/das24rules

62 rambler classic (casper)
63 rambler american (rosie)
82 eagle sx4 (honeybadger)
82 eagle sw (rottywagon)
79 spirit (drag race car)


Top
 Profile  
 
PostPosted: Tue Jun 11, 2013 6:09 am 
Offline
Eagle
User avatar

Joined: Fri Feb 08, 2013 4:49 pm
Posts: 1882
Location: Toledo, Iowa USA
Good find. Yeah, those belts and hoses should probably be replaced. Although, my '80 Concord has most of that factor stuff intact too. Not sure, but the plugs could be factory as well.

_________________
Doug, formerly known as IowaEagle.
"You gotta know the basics before you do the mods."
"I was in to AMC's before AMC's were cool."

1970 Ambassador SST 2 dr Hard Top Coupe
1980 Concord DL 4 dr
1982 Eagle SX/4 Sport


Top
 Profile  
 
PostPosted: Tue Jun 11, 2013 6:48 am 
Offline
Rebel

Joined: Sun Apr 28, 2013 6:41 am
Posts: 152
Location: Seattle wa
very cool


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 8 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Reputation System ©